After you create or import a data table, you have several options that will help you manage this table. To access these options, click the icon in the upper-right corner of the table view:

  • View record history: This is one of the most important features of Worksheet Systems. It allows you to track all changes to each row of your table. You can see who changed the data in the row, and when it was changed.

  • Show row in dialog: Open a dialog with all columns available as fields, for more convenient editing. You can also add a new row from this dialog.

Please note that the system highlights all changed rows with red. To record those changes, click Save. As a result, the system will show a message with details about the changes.

  • Format Current Column: Edit the display details of the selected column, with the following options available:
    • Caption: Enter the name of the field, if you want to make it different from the name that it has in the main table.
    • Width: Specify the custom width of the field.
    • Display Format: Define how to display your data. Options here depend on the field data type.

For numeric fields: Select the format in which you want to display your numbers, and then select how you want to sum up these numbers in the footer of your datasheet.

For text fields:

  • Single Line: Default single-line text.
  • Multi Line (Details dialog): Splits the long text in multiple lines for better readability in the details dialog. This dialog appears when you select the Show row in dialog option. Here is an example of multiline text:

  • Drop down from comma separated text: Adds a drop-down with data that you specify under Source text.
  • Drop down from Data Table Source: Adds a drop-down with data that you specify under Source Data Table and Source Field.

And the rest of the table management options are:

  • Modify Table Query: Open Query Editor to edit the table query.
  • Fill all rows: Highlight all rows with red.
  • Fill empty rows: Highlight all empty rows with red.
  • Export to Excel/Export to CSV: Export the table either to Excel or to CSV.